View unanswered posts | View active topics It is currently Wed Dec 13, 2017 5:19 am



Reply to topic  [ 11 posts ]  Go to page 1, 2  Next
Unsatisfactory experience with newer ATI carts? Read on 
Author Message
Private
User avatar

Joined: Sun Nov 09, 2008 8:18 pm
Posts: 47
Location: Dortmund, Germany
Reply with quote
It has stopped working again. I had to downgrade to Catalyst 13.10 to get good FPS again.

*** Outdated ***

Having unsatisfactory FPS in ET with newer ATI cards and/or problems adjusting the visuals, i.e. gamma, intensity, mapoverbrightbits and so on and still not getting the visuals as you used to on older cards?

The solution is pretty simple. The problem stems from ET only supporting an OpenGL extension string up to 4096 chars, but modern cards have so many OpenGL extensions that this size does not suffice. The rest of the extension string gets cut off, and often in the cut off part of it the extensions important to ET performance and visual quality are found.

There is a simple fix, though. There is a file called atiogl.xml that supports enabling certain OpenGL extensions per executable file, and restricting the extension string size, guaranteing that the required extensions will end up in the part that is read by ET.

In Windows, this file can be found at C:\windows\atiogl.xml, in *nix it's probably /etc/ati/atiogl.xml or some such.

So:
  • Find atiogl.xml
  • Edit it (right click->edit in Windows)
  • Find the section with et.exe or et.x86 and replace it with
    Code:
       <!-- et -->
       <profile exename="et.x86">
          <OpenGLCaps>0x00001000</OpenGLCaps>
          <OpenGLCapsEx>0x00000000</OpenGLCapsEx>
          <OpenGLCapsEx2>0x20000000</OpenGLCapsEx2>
          <maxExtStrLen>0x1000</maxExtStrLen>
       </profile>
       <profile exename="et.exe">
          <OpenGLCaps>0x00001000</OpenGLCaps>
          <OpenGLCapsEx>0x00000000</OpenGLCapsEx>
          <OpenGLCapsEx2>0x20000000</OpenGLCapsEx2>
          <maxExtStrLen>0x1000</maxExtStrLen>
       </profile>
  • save the file


That's it! ET should now be running at 100+ FPS, as is expected!




Original post:
Quote:
Hey guys, last week I bought a new GFX card, a Radeon R9 270X.

Now I only get 10-20 FPS max in ET. I can play stuff like CoD: Ghosts with 60+ FPS with almost max settings.
I can confirm that ET is indeed using the graphics hardware and not a software renderer.
Wiping and reinstalling ET did not change anything.

Any ideas? :wall:

_________________
SPEED: FAST MOVEMENT
Image


Last edited by nightfly on Sat Dec 14, 2013 10:03 pm, edited 2 times in total.



Mon Dec 09, 2013 3:33 pm
Profile
Private

Joined: Sat Jan 16, 2010 3:22 pm
Posts: 27
Reply with quote
You need to get older drivers. Amd is so great that they dont support ET anymore so you will have to downgrade your gfx drivers


Mon Dec 09, 2013 4:40 pm
Profile
Private 1st Class
Private 1st Class
User avatar

Joined: Fri Apr 03, 2009 10:36 am
Posts: 218
Location: Styria, Austria
Reply with quote
well Et is OPEN GL and ATI do not perform exactly well on this API

Then again I got a 4870 and most of the maps play perfectly well.

what cfg are you using?


Mon Dec 09, 2013 4:40 pm
Profile
Captain
Captain
User avatar

Joined: Tue Nov 11, 2008 7:17 pm
Posts: 1163
Location: Germany
Reply with quote
You can extract a old "atioglxx.dll" version and put it into you etfolder. No need to downgrade the hole driver. I have used this method years long without a problem. You might need to find a good version of it thou. Don't know if my old version will work with a new gfx card.

_________________
ImageImageImage


Mon Dec 09, 2013 7:51 pm
Profile
Private
User avatar

Joined: Sun Nov 09, 2008 8:18 pm
Posts: 47
Location: Dortmund, Germany
Reply with quote
Hey guys, many thanks! Also thank you Moses, will try the DLL immediately!

So, does nVidia have better OGL capabilities?

Although I wonder: Will the drivers for workstation graphics cards of the same make (FireGL etc.) work? I mean, AMD can hardly sell these with such bad OGL support if they're supposed to be used with Autodesk software, Maya etc. which runs on OGL exclusively IIRC.

Techhead, I have tried both old (optimized) cfg and a freshly wiped config, no result.
My previous card (HD 6xxx) worked OK, although I didn't get anything like the 120+ FPS I got with the Radeon 9800 years ago.. ~70-80 FPS at most. Stupid, even a Geforce 4 Ti ran ET at 110 FPS. Damn sh*t :( :complain:

_________________
SPEED: FAST MOVEMENT
Image


Mon Dec 09, 2013 10:56 pm
Profile
Captain
Captain
User avatar

Joined: Tue Nov 11, 2008 7:17 pm
Posts: 1163
Location: Germany
Reply with quote
forced vsync on?

_________________
ImageImageImage


Mon Dec 09, 2013 11:08 pm
Profile
Private
User avatar

Joined: Sun Nov 09, 2008 8:18 pm
Posts: 47
Location: Dortmund, Germany
Reply with quote
Moses, I tried your DLL but ET crashed on me (running on Windows 7 64 bit, if that matters).

I tried one found here: http://forums.steampowered.com/forums/s ... ?t=1990348
and it works ok. FPS mostly hovers around 50-70, so I fixed it to 43 FPS and it works good enough. Thanks again! :rock: :-D

_________________
SPEED: FAST MOVEMENT
Image


Mon Dec 09, 2013 11:43 pm
Profile
Private
User avatar

Joined: Sun Nov 09, 2008 8:18 pm
Posts: 47
Location: Dortmund, Germany
Reply with quote
Hey guys, I solved it! I'm now running at 100+ FPS!!
See original topic post.

I'll also try to mod a FirePro/FireGL driver to support my R9 270x, since that should result in even higher OpenGL performance. I'll keep you posted on the progress. I'll be using the information here:

  • http://forums.guru3d.com/showthread.php?t=313065
  • http://benchmark3d.com/mod-catalyst-driver-to-add-supported-cards
  • http://www.overclock.net/t/1403233/amd-firepro-modded-drivers-13-152-4-whql-for-radeon-cards-11-22-2013

:rock: :lol:

_________________
SPEED: FAST MOVEMENT
Image


Sat Dec 14, 2013 10:02 pm
Profile
Captain
Captain
User avatar

Joined: Tue Nov 11, 2008 7:17 pm
Posts: 1163
Location: Germany
Reply with quote
moved to FAQ, nice work nightfly :)

_________________
ImageImageImage


Sun Dec 15, 2013 11:22 am
Profile
Private
User avatar

Joined: Sun Nov 09, 2008 8:18 pm
Posts: 47
Location: Dortmund, Germany
Reply with quote
I've had enough :wall: I'm getting an nVidia card (GTX 970). F*ck AMD :evil: :swear:

_________________
SPEED: FAST MOVEMENT
Image


Wed Jan 21, 2015 7:08 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 11 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.